バージョン まとめ

ここは、 foobar2000 のバージョンごとの違いをまとめたページです。

バージョンごとに何が違う?

foobar2000 は、今までに何回かメジャーアップデートが行われ、その度に機能、インターフェース、コンポーネント(拡張機能)の互換性、対応OSなどが変わってきました。 そのため、メジャーアップデートされる前とされた後のバージョンの間ではこれらに違いがあります。

foobar2000 のアップデートの概略
  • v0.8 (このときは Windows 95,98,ME,NT,2000,XP に対応していた)
  • v0.8.3
  • v0.9 (デザインを始め様々な機能が一新。 v0.8 でのコンポーネントが使えなくなった。Windows ME 以前では使用不可に。
  • v0.9.4.5
  • v0.9.5 (デザインや機能が大きく変更された。Windows 2000 では使用不可に。
  • v0.9.5.2
  • v0.9.5.3いくつかの便利なコンポーネントが 使用不可にされた

現在の状況を表にまとめると以下のようになります。

95,98,ME,NT2000XPVista v0.8.x 用コンポーネントv0.9.x 用コンポーネントデフォルト*1でのUI
v0.8~v0.8.3*2 使用可使用不可シンプル、カスタマイズ性は低い
v0.9~v0.9.4.5×使用不可使用可(v0.9.5 以降でしか使えない一部のコンポーネントを除く)シンプル、カスタマイズ性は低い
v0.9.5~v0.9.5.2×× 使用可*3多機能、カスタマイズ性は高い
v0.9.5.3~ 使用可(v0.9.5.3 で使用不可にされた一部のコンポーネント(一覧)を除く)

この表から分かるように、結構ややこしいことになっています。なので最初のうちは v0.8.3 以前 と v0.9 以降 というおおまかに二つのグループに分けて考え、v0.8.3 以前専用のコンポーネントは v0.9 以降では使えず、v0.9 以降のコンポーネントは v0.8.3 以前では使えない と理解しておいたほうが比較的分かりやすいと思います。 さらに v0.9 以降 を使う場合、 v0.9.5.3 から、一部の便利なコンポーネントが使用不可にされていて、もしこれらのコンポーネントを導入したい場合は v0.9 ~ v0.9.5.2 を使う必要がある、ということも知っておいたほうがいいでしょう。

どのバージョンをインストールすればいい?

現在では、特別な事情がなければ、インストールするバージョンは

の4種類から選ぶのが一般的です。

基本的には環境に応じて次のようにバージョンを選ぶといいと思います。

「ある程度カスタマイズしようと思っているけれど、"v0.9.5.2 で使用不可にされたコンポーネント"には具体的にどんな機能があるかよく分からない」という場合は、リリースされてから時間が経っている v0.9.5.2よりは、比較的安定している最新版を使うほうが無難かもしれません。また、新しくリリースされたコンポーネントの中には、最新版では正常に動くが v0.9.5.2 では不具合が起こるものも、数は多くありませんが存在します*4。 もし最新版に不満があり v0.9.5.2 に乗り換えたくなった場合は v0.9.5.2 のインストーラーをダウンロードし上書きインストールすれば大丈夫です。ただし、上書きインストールする際はコンポーネントの互換性に気をつけてください。

バージョンごとのまとめ

v0.9.x

v0.9.5.3 ~

ダウンロード
http://www.foobar2000.org/
インストール、日本語化の解説
インストール・日本語化 (v0.9.5)
このバージョンについての詳細
v0.9.5.3 まとめ

v0.9.5 ~ v0.9.5.2

ダウンロード
http://www.filehippo.com/download_foobar2000/4051/
インストール、日本語化の解説
インストール・日本語化 (v0.9.5)
このバージョンについての詳細
v0.9.5 まとめ

v0.9 ~ v0.9.4.5

ダウンロード
http://www.filehippo.com/download_foobar2000/3301/
インストール、日本語化の解説
インストール・日本語化 (v0.9x)
このバージョンについての詳細
v0.9 まとめ

v0.8.x

ダウンロード
http://www.filehippo.com/download_foobar2000/55/
インストール、日本語化の解説
インストール・日本語化
解説ページ
foobar2000v0.8

*1 コンポーネントを導入することでUIを変更することも出来ます
*2 一応インストールはできるようだが、安定して動作するかは不明
*3 調査したわけではないので、もしかしたらこのバージョンで使えないコンポーネントがあるかもしれません
*4 例えば Columns UI の 0.3.6.6 以降

Last-modified: 2016-02-03 (水) 23:00:00 (1294d)